re = /^([^_]*_[^_]*).*/
str = '1-343-43Hello_2_323.14_fdh-99H'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result