$re = '/^(?:[0-9]{2}:?){3}/m';
$str = '03:32:33
03:32:3
0:32';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);