# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^
(?P<group>
(?P<structured>
(?P<single>
(?P<tag_first>
(?P<tag>
\d+(?:\/\d+)+
|
(?P<repnum>\$+(?:@\^*-?\d*)?)
|
[\w:!-]
)++
(?P<attr>
(?P<short_attr>
\.
(?P<short_val>
(?P>repnum)
|
[\w:!-]
)*
|
\#(?P>short_val)*
)
|
(?P<long_attr>
\[
(?P<attr_pair>
(?P<attr_name>
\\(?:\\{2})*["'\s]
|
[^\[\]"'\s\\]
)+
\.?
(?P<equal_val>
=
(?P<attr_val>
(?P<unquoted_val>
\\(?:\\{2})*[\[\]"'\s]
|
[^\[\]"'\s\\]
)+
|
(?P<quoted_val>
(?P<quote>["'])
(?:
(?P<escaped_all>\\(?:\\{2})*.)
|
[^"'\n\\]
)*
(?P=quote)
)
)?
)?
)?
(?:\s+(?P>attr_pair))*
\]
)
)*
|
(?P>attr)+
)
(?P<tag_rest>
(?P<text>
\{
(?P<text_content>
(?P>escaped_all)
|
[^{}\n\\]
)*
\}
)
(?P>attr)*
(?:
(?P<rep>\*\d*+)?
(?P>attr)*
(?P<close>\/)?
|
(?P>close)?
(?P>rep)?
)
|
(?P>rep)
(?P>attr)*
(?P>text)?
(?P>attr)*
(?P>close)?
|
(?P>close)
(?P>rep)?
)?
|
(?P<text_first>(?P>text)(?P>attr)*)
(?P<text_rest>
(?P>rep)
(?P>attr)*
(?P>close)?
|
(?P>close)
(?P>rep)?
)?
)
(?:
(?P<relation>[>+]|\^+)
(?P>group)*
)?
)
|
\(
(?P>group)*
\)
(?P>rep)?
(?P>relation)?
)+
$
"""
test_str = (">>> tag <<<\n"
"tag\n"
"$\n"
"tag$with$@^^^-2repnum\n"
"1\n"
"1/2\n"
"1/2/3\n"
"tag1/2with1/2/3fraction\n"
"tag$@with1/2both\n"
"ri:a\n"
"!\n"
"!!!\n"
"-\n"
":\n\n"
"===XXX===\n"
"@\n"
"&\n\n"
">>> short attr <<<\n"
"#\n"
"###\n"
"#id\n"
"#id1#id2\n"
"#id$@^^^-2\n"
".\n"
".#\n"
"...\n"
".class\n"
".class1.class2\n"
".class#id.class\n"
".class$@^-2type\n"
".class-data\n"
".!class\n"
".class:subclass\n\n"
"===XXX===\n"
".@\n"
".汉字\n\n"
">>> long attr <<<\n"
"[]\n"
"[key]\n"
"[key.]\n"
"[key...]\n"
"[key=]\n"
"[key.=]\n"
"[key=val]\n"
"[key.=val]\n"
"[key='val']\n"
"[key='val with space']\n"
"[key='val\\\\\\'ue']\n"
"[key1=val1 key2=val2]\n"
"[][]\n"
"[key][key]\n"
".class[key]\n"
"[key].class\n"
"[汉字=汉字]\n\n"
"===XXX===\n"
"[\\[]\n"
"[key='val\\\\'ue']\n\n"
">>> text <<<\n"
"{}\n"
"{text}\n"
"{text with space}\n"
"{text with escaped \\{ and \\}}\n"
"{汉字}\n"
"tag{text}\n"
".attr{text}\n"
"{text}.attr\n\n"
"===XXX===\n"
"{\\\\{}\n"
"{{}}\n\n"
">>> repeater <<<\n"
"tag*2\n"
".attr*2\n"
"{text}*2\n"
".attr{text}*2\n"
".attr{text}.attr*2\n\n"
"===XXX===\n"
"*2\n"
"tag*2*2\n\n"
">>> self-close <<<\n"
"tag/\n"
".attr/\n"
"{text}/\n"
"tag*2/\n"
"tag/*2\n"
".attr{text}.attr/\n"
".attr*2.attr{text}.attr/\n"
".attr{text}.attr*2.attr/\n"
".attr{text}/*2\n"
"tag*2{text}/\n\n"
"===XXX===\n"
"/*2\n"
"tag//\n\n"
">>> child <<<\n"
"tag>tag\n"
"tag.class*2>tag[key]/\n"
"tag>\n\n"
"===XXX===\n"
">tag\n"
"tag>>\n\n"
">>> sibling <<<\n"
"tag+tag\n"
".class/>[key]+.attr/*2\n"
"tag[key]tag\n"
"tag{text}tag\n"
"tag*2tag\n"
"tag/tag\n\n"
"===XXX===\n"
"+tag\n"
"tag++\n\n"
">>> parent <<<\n"
"tag^tag\n"
"tag^^^\n"
"tag>tag+tag^tag\n\n"
"===XXX===\n"
"^tag\n\n"
">>> group <<<\n"
"()\n"
"(())\n"
"(tag)\n"
"(tag)(tag)\n"
"((tag)(tag))\n"
"tag>(tag.class)\n"
"tag>(tag>tag+tag)\n"
"(tag>(tag+tag)*2)*2\n"
"(tag)tag\n"
"(tag>).class\n"
"(tag)*2^tag\n"
"(tag*2)^tag\n"
"(tag>)^tag\n"
"(tag)^\n\n"
"===XXX===\n"
"(\n"
"(()")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.