using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-0+\.(0)+\b|\.0+\b|\b0+(?=\.\d*[1-9])";
string substitution = @"$1";
string input = @"2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101
0.001,-0.03
2,3,-4,0,0,.03,2.01,.001,-.03,101
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}