re = /-0+\.(0)+\b|\.0+\b|\b0+(?=\.\d*[1-9])/
str = '2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101
0.001,-0.03
2,3,-4,0,0,.03,2.01,.001,-.03,101
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result