import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z]+(?:[ \\t]+[a-zA-Z]+)*)(?:[ \\t]+(\\d+)(?:[ \\t]+(.+))?)?";
final String string = "Battery Bank 1\n"
+ "Battery Bank 1 Segments\n"
+ "Battery Bank 1 Warranty Logger\n"
+ "Battery Bank 10\n"
+ "Battery Bank 10 Segments\n"
+ "Battery Bank 10 Warranty Logger\n"
+ "BSU\n"
+ "BSU 1\n"
+ "PCS 3\n"
+ "PCS 1\n"
+ "System\n"
+ "System Meter";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}