# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!version-[\d.]+$).*12\.3.*$"
test_str = ("bugfix-ISSUE-123-some-details-version-12.3\n"
"ISSUE-1234-some-other-details-version-12.3\n"
"bugfix-12.3\n"
"bugfix2-12.3\n"
"12.3stuff\n"
"stu12.3ff\n\n"
"// match everything above, but don't match anything from below\n\n"
"master\n"
"version-12.3\n"
"version-3.21\n"
"some-other-branch\n"
"bugfix-3.21\n"
"test")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.