# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-z0-9\s]{1,11})(\s)(.*)/$1/;t' <<< "The quick brown fox jumped over the fence, K: 11"