package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-z0-9\s]{1,11})(\s)(.*)`)
var str = []byte(`The quick brown fox jumped over the fence, K: 11`)
var substitution = []byte("$1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}