use strict;
my $str = 'The quick brown fox jumped over the fence, K: 11';
my $regex = qr/([A-z0-9\s]{1,11})(\s)(.*)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";