Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([a-zA-Z0-9\_]*)\:\s?([A-Za-z0-9\"\']*)
/
mg
Input 1
1
New
classes = { Romanian: 1, English: 2, French: 3, German: 4, Latin: 5, Math: 6, Physics: 7, Chemistry: 8, Biology: 9, History: 10, Geography: 11, Social: 12, Religion: 13, Music: 14, Arts: 15, Sports: 16, ComputerScience: 17, IT: 18 };