import Foundation
let pattern = #"([a-zA-Z0-9\_]*)\:\s?([A-Za-z0-9\"\']*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
classes = {
Romanian: 1,
English: 2,
French: 3,
German: 4,
Latin: 5,
Math: 6,
Physics: 7,
Chemistry: 8,
Biology: 9,
History: 10,
Geography: 11,
Social: 12,
Religion: 13,
Music: 14,
Arts: 15,
Sports: 16,
ComputerScience: 17,
IT: 18
};
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)