package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:<ins class="thisisfirstscript")([\s\S]*?)(?:data-slot="4397140188"><\/ins>)`)
var str = `<ins class="thisisfirstscript"
style="display:inline-block;width:336px;height:280px"
data-client="ABCD"
data-slot="4397140188"></ins>
<ins class="thisissecondscript"
style="display:inline-block;width:336px;height:280px"
data-client="CDEF"
data-slot="4496122889"></ins>
<ins class="thisisfirstscript"
style="display:inline-block;width:336px;height:280px"
data-client="ABCD"
data-slot="4397140188"></ins>`
var substitution = "$1index.php"
fmt.Println(re.ReplaceAllString(str, substitution))
}