# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<ins class=\"thisisfirstscript\")([\s\S]*?)(?:data-slot=\"4397140188\"><\/ins>)"
test_str = ("<ins class=\"thisisfirstscript\"\n"
" style=\"display:inline-block;width:336px;height:280px\"\n"
" data-client=\"ABCD\"\n"
" data-slot=\"4397140188\"></ins>\n\n"
" <ins class=\"thisissecondscript\"\n"
" style=\"display:inline-block;width:336px;height:280px\"\n"
" data-client=\"CDEF\"\n"
" data-slot=\"4496122889\"></ins>\n\n"
"<ins class=\"thisisfirstscript\"\n"
" style=\"display:inline-block;width:336px;height:280px\"\n"
" data-client=\"ABCD\"\n"
" data-slot=\"4397140188\"></ins>")
subst = "$1index.php"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.