re = /<(i|b).+>(.+)<\/(i|b)>/
str = '<i style=I>asd</i>
<i style=I>asd</i>
<i style=I>asd</i>'
subst = '<$1>$2</$3>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result