import Foundation
let pattern = #"\d*([ A-Z]+((SL[1-9])?[ ]?[0-9A-Z]+)?,)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"14 College Rd, Maidenhead, Windsor and Maidenhead SL6 6BN, UK"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}