using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(#+.*?)With Space";
string substitution = @"$1WithSpace";
string input = @"#ThisIsaHashtagWith Space";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}