re = /[$]row[[]([^']+?)[\]]/m
str = '$row[number]; $row[user];
$row[\'number\']; $row[\'user\'];'
subst = '$row[\'$1\']'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result