// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[$]row[[]([^']+?)[\]]").unwrap();
let string = "$row[number]; $row[user];
$row['number']; $row['user'];";
let substitution = "$row['$1']";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}