re = /(?n)(common_group) (?<group_name>not_common_group) \1/
str = 'common_group not_common_group not_common_group'
# Print the match result
str.match(re) do |match|
puts match.to_s
end