using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"fu[^tsn]";
string input = @"fu
tofu
snafu
futz
fusillade
functional
discombobulated ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}