package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`fu[^tsn]`)
var str = `fu
tofu
snafu
futz
fusillade
functional
discombobulated `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}