package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`&N\|(.*|$)\/`)
var str = `Nr.: &N|1|2|3|4|5|6|7 / 8|9|10|11|12 / 2014`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}