re = /(?<identifier>[a-zA-Z][a-zA-Z0-9_]*)(?<specifier>[%&@!#$])?(?:\sAs)?\s(?:(?<reference>[a-zA-Z][a-zA-Z0-9_]*)\s)?=\s(?<value>[^',]+(?:(?:(?!").)+")?),?/
str = 'foo = "123,"
foo = 123,
foo = "123"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end