import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<mrn>\\d{8}).*\\s+(?P<lastname>\\D+),(?P<firstname>\\D+)\\s+(?P<dob>[\\d\\/]{10})\\s(?P<age>\\w+)\\s(?P<sex>\\w)";
final String string = "$\n"
+ "61731278 10141113787\n"
+ "Trauma,Test IV \n"
+ "01/01/1880 135Y M\n"
+ "7/27/2015\n"
+ "AC10141113787\\";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}