re = /Set-Cookie:( ([^=\n]+)=([^;\n]+);)/m
str = 'Set-Cookie: CookieFirst=ValueFirst; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly
Set-Cookie: CookieSecond=ValueSecond; expires=Tue, 01 Jan 2018 00:00:00 GMT; domain=.site.com; path=/; httponly'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end