using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https:\/\/)?(.*?)(?:\.ingest\.sentry\.io)(.*)$";
string input = @"https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}