$re = '/^(?:https:\/\/)?(.*?)(?:\.ingest\.sentry\.io)(.*)$/m';
$str = 'https://87230a61de33450b964afbc0814884ec@p2238591.ingest.sentry.io/1504772008177343';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);