import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=<ul\\s+id=\"\"matchMe\"\"\\s+type=\"\"square\"\"\\s*>) # match start with <ul id=\"matchMe\"...\n"
+ "(?> # atomic group / don't backtrack (faster)\n"
+ " <!-- .*? --> | # match xml / html comment\n"
+ " <[^>]*/\\s*> | # self closing tag\n"
+ " (?<opentag><(?!\\s*/)[^>]*[^/]>) | # push opening xml tag\n"
+ " (?<-opentag><\\s*/[^>]*[^/]>) | # pop closing xml tag\n"
+ " [^<>]* # something between tags\n"
+ ")* # match as many xml tags as possible\n"
+ "(?(opentag)(?!)) # ensure no 'opentag' groups are on stack";
final String string = "<html>\n"
+ "<body>\n"
+ "<div>\n"
+ " <br />\n"
+ " <ul id=\"matchMe\" type=\"square\">\n"
+ " <li>stuff...</li>\n"
+ " <li>more stuff</li>\n"
+ " <li>\n"
+ " <div>\n"
+ " <p>Lorem ipsum< /p>\n"
+ " <hr class=\"important\" / >\n"
+ " <span>still more</span>\n"
+ " <ul>\n"
+ " <li>Another >ul<, oh my!</li>\n"
+ " <li>...</li>\n"
+ " </ul>\n"
+ " </div>\n"
+ " </li>\n"
+ " </ul>\n"
+ "</div>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}