$re = '/\$\\\\\w*{[^}]+}(*SKIP)(*F)|{[^}]*}/m';
$str = 'Lorem Ipsum $\\mathbb{R}$ dolore. {Author} $\\{1,\\dotsc,n}$
$\\mathbb{R} $ dolore. {Author}';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;