re = /:smile_([0-9]{0,2}):/
str = ':smile_1:
:smile_2:
:smile_3:
:smile_4:
:smile_5:
:smile_6:
:smile_7:
:smile_8:
:smile_9:
:smile_10:
:smile_11:
:smile_12:
:smile_100:'
subst = '<img src="/$1.png">'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result