// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r":smile_([0-9]{0,2}):").unwrap();
let string = ":smile_1:
:smile_2:
:smile_3:
:smile_4:
:smile_5:
:smile_6:
:smile_7:
:smile_8:
:smile_9:
:smile_10:
:smile_11:
:smile_12:
:smile_100:";
let substitution = "<img src=\"/$1.png\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}