re = /(\{[^{}]+\})/
str = '{\'a\':1\'}{{\'a\':1, \'b\':2}{\'c\':3}}{\'a\':4, \'b\':6}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end