package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{11}$`)
var str = `12345678912
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}