const regex = /(Mode:\S*)\s*(Frequency:\S*\s*GHz)\s*(Access Point:\s*\S*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Mode:\\S*)\\s*(Frequency:\\S*\\s*GHz)\\s*(Access Point:\\s*\\S*)', 'g')
const str = `Mode:Managed Frequency:2.462 GHz Access Point: 00:00:00:00:00:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}