#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\r\n?|\n){2,}"
Local $sString = "Text of example in line 1." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"The text is very nice..." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"The end."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)