re = /(?:^|,\s*)BIG BOAT\s*(?=,|$)/m
str = 'BIG BOAT , GREEN CAR,BIG BOAT, YELLOW TRUCK, BIG BOAT, AMAZON ECHO, BIG BOAT , BLUE CAR , BIG BOAT BLUE, TABLE, GLASSES, BIG BOAT'
subst = 'TEST'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result