#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\D+)(\d+)(?=((?!\)).)*\(|[^()]*$)"
Local $sString = "1Hello2Hai (in 2:3) 3hi 4 bye"
Local $sSubst = "$1\n$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)