using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\D+)(\d+)(?=((?!\)).)*\(|[^()]*$)";
string substitution = @"$1\n$2";
string input = @"1Hello2Hai (in 2:3) 3hi 4 bye";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}