use strict;
my $str = '1Hello2Hai (in 2:3) 3hi 4 bye';
my $regex = qr/(\D+)(\d+)(?=((?!\)).)*\(|[^()]*$)/p;
my $subst = '$1\\n$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";