$re = '/^(973|(208[0-9]*))?$/m';
$str = '973
2081
208
02081';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);