use strict;
my $str = '{{mul|ab|ab|ab|ab|ab|ab}}
{{mul|aa|ab }}machintruc
brun}}{{mul|aa|ab}}
{{mul|fr|en|de}}[http//truc]
{{mul|fi|luo|en-gb|zh-hant }}{{chapitre|
{{mul|de|nl|fi|luo|en-gb|zh-hant }} {{lien web|
{{mr}} Trucmuche';
my $regex = qr/\{\{mul([^\} ]*) *\}\}([^\s])/mp;
my $subst = '{{mul$1}} $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";