const regex = /(<\/[^>]+>)[^<]*(<[^>]+>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/[^>]+>)[^<]*(<[^>]+>)', 'g')
const str = `<h1>This is the title</h1>This is a bit of text with no HTML around it<p>This is within a paragraph tag</p>`;
const subst = `(<\/[^>]+>)[^<]*(<[^>]+>)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);