$re = '/(<\/[^>]+>)[^<]*(<[^>]+>)/';
$str = '<h1>This is the title</h1>This is a bit of text with no HTML around it<p>This is within a paragraph tag</p>';
$subst = "(<\/[^>]+>)[^<]*(<[^>]+>)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;