package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{2})([^:]+)(:\d{2}){2}`)
var str = `Sat 02 May 2015 19:54:36 +0530`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}