$re = '/(\d{2})([^:]+)(:\d{2}){2}/m';
$str = 'Sat 02 May 2015 19:54:36 +0530';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);