#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^193\.172\.166\.(1[0-9][0-9]|2[0-4][0-9]|25[0-1])$"
Local $sString = "193.172.166.20" & @CRLF & _
"193.172.166.99" & @CRLF & _
"193.172.166.100" & @CRLF & _
"193.172.166.151" & @CRLF & _
"193.172.166.155" & @CRLF & _
"193.172.166.200" & @CRLF & _
"193.172.166.251" & @CRLF & _
"193.172.166.252"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")