const regex = /^193\.172\.166\.(1[0-9][0-9]|2[0-4][0-9]|25[0-1])$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^193\\.172\\.166\\.(1[0-9][0-9]|2[0-4][0-9]|25[0-1])$', 'gmi')
const str = `193.172.166.20
193.172.166.99
193.172.166.100
193.172.166.151
193.172.166.155
193.172.166.200
193.172.166.251
193.172.166.252`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}