import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:^|\\G(?<!^)[^'\"]*\")[^\"]*+(?:\"[^\"']*\"[^\"]*)*+\"|\\G(?<!^))[^'\"]*+(')";
final String string = "\" This is a random sentence ' with 'a quote, the quote should match\"\n"
+ "\" There is no quote here thats the problem\" Anything here should not match but now it does: ' .\n"
+ "\" Some text \" some more text \" this is a quote : ' that should match\"\n"
+ "\" When there is a quote (') here, the other one does not work : \" ' and that's perfect \" even if you remove the first one this : \" (') \" will make it work because of the greedy ( I think ) but ifyou remove those between parenthesis, the other one is matching as of now, which I do not want to happen.\"\n"
+ "Another example would be this one : The following should not work, but it does \"This is being quoted\" not this: (') \" and this is also being quoted \"\n"
+ "\"'\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}