Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
((?:(?(?=Fig\.|\d+\.\d).+?(?=\s)|[^.!?])+(?=\.))+)
/
gi
Input 1
1
New
This sentence should be captured because it contains the number 20. This sentence should be captured because it contains the reference term 20AA. This sentence should not be captured because it does not contain a number or reference term.